$re = '/$/m';
$str = 'title_shoot_0001
title_shoot_0002
title_shoot_0003
title_shoot_0004
title_shoot_0005
title_shoot_0006
title_shoot_0007
title_shoot_0008
title_shoot_0009
title_shoot_0010';
$subst = "_photographer";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;