re = /(?<!\\)(?:\\{2})*\\(?!\\)/
str = '\\\\\\\\\\\\\\\\asfasfasdf\\\\\\\\\\\\\\dfdf\\\\dfdfdf\\\\\\asdfadsf\\'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end