import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((1?[\\d]?[\\d]|2([0-4][\\d]|5[0-5]))[.]){3}(1?[\\d]?[\\d]|2([0-4][\\d]|5[0-5]))$";
final String string = "10.0.0.30";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}