package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?P<pattern1>(?P<pattern2>^[0-9]+$)|.*)$`)
var str = `12345678
123ert
1244
erty
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}