re = /<!--.*?-->/
str = 'lorem ipsum <!-- hidden --> sir doloret <!-- hidden again -->'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end