$re = '/(?<=Y\|)[^|]*/m';
$str = 'Y|ZXIETV| |N|100|Y||ZXIET|ZXIET|Nl';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);