$re = '/(\w+)(?:-\w+)?\.jpg/i';
$str = '477547755-large.jpg';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);