$re = '/(\d{1,2}[^\d]*)(?=\d|\b)/m';
$str = '1this12string';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);