re = /^(:(=[^:\/]{4,253})(?!-)[a-zA-Z0-9-]{1,63}(?<!-)(?:\.(?!-)[a-zA-Z0-9-]{1,63}(?<!-))*(?::[0-9]{1,5})?\/)?(?<image>(?![._-])(?:(?:[a-z0-9._-]*(?::[0-9]{1,5})?))(?<![._-])(?:\/(?![._-])[a-z0-9._-]*(?<![._-]))*)(?:(?<tag>(?::(?![.-])[a-zA-Z0-9_.-]{1,128}))|(?<sha>@sha256:[0-9a-f]{64}))?$/
str = '192.168.0.1:90000/ubuntu/kek@sha256:45b23dee08af5e43a7fea6c4cf9c25ccf269ee113168c19722f87876677c5cb2'
# Print the match result
str.match(re) do |match|
puts match.to_s
end