re = /(\d+\.\d+\.\d+\.\d+).*\[(.+)\].*?"([A-Z]+)\s(\S+)\s(HTTP\/\d+\.\d+).*?(\d+)\s(\d+).*?(\w.+)".*?",".*?(\d+)}/m
str = '{"resource":{"attributes":{}},"scope":{"attributes":{}},"logRecord":{"attributes":{"log.file.name":"xxxx.log","log.file.path":"X:\\\\xxx\\\\xxxx.log"},"body":"1.1.1.1 - - [04/Mar/2023:23:16:59 +0000] \\"HEAD /xxxx-xxxxx%20systematic%20internet%20solution_xxx-xxx.png HTTP/1.1\\" 200 1091 \\"-\\" \\"Mozilla/5.0 (Windows 95) AppleWebKit/5361 (KHTML, like Gecko) Chrome/36.0.849.0 Mobile Safari/5361\\"","observedTimeUnixNano":1716203580594785300}}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end