$re = '/([^,.]+)\./m';
$str = 'a. Lorem ipsum dolor sit amet, consectetur adipiscing elit, d. Donec euismod magna velit, ac tincidunt nisl faucibus eu';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);