package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([a-zA-Z]+[0-9]+)+`)
var str = `a12s34`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}