import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\\(?<=(0_ASW|10_BSW)\\\\)([A-Za-z0-9]+)";
final String string = "C:\\MyPath\\0_ASW\\Mod2000\n"
+ "C:\\MyPath\\0_ASW\\Mod2005\\SubDir\n"
+ "C:\\MyPath\\10_BSW\\ModA\\SubDir\n"
+ "C:\\MyPath\\10_BSW\\ModB\n"
+ "C:\\MyPath\\10_BSW\\ModC\\\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}