const regex = /(?<=.)[^@\n](?=[^@\n]*[^@\n]@)|(?:(?<=@.)|(?!^)\G(?=[^@]*$)).(?!$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=.)[^@\\n](?=[^@\\n]*[^@\\n]@)|(?:(?<=@.)|(?!^)\\G(?=[^@]*$)).(?!$)', 'gm')
const str = `foo@bar.com
foo-and.more!here@bar.com
fo@bar.com
f@bar.com`;
const subst = `*`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);