$re = '/\b((VF2)|(VF(F|Q)[ .]VF(F|Q)))\b/mi';
$str = '# MATCH
Movie.2022.MULTi.VFF.VFQ.1080p.NF.WEB-DL.DDP5.1.TrueHD.Atmos.x264-Group
Movie.2022.VF2.1080p.NF.WEB-DL.DDP5.1.Atmos.TrueHD.x264-Group
# DON\'T MATCH
Movie.2022.VFF.1080p.NF.WEB-DL.DDP5.1.Atmos.TrueHD.x264-Group
Movie.2022.MULTi.VF.1080p.NF.WEB-DL.DDP5.1.TrueHD.x264-Group
Movie.2022.VFQ.1080p.NF.WEB-DL.DDP5.1.TrueHD.x264-Group
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);