$re = '/(?-s)^(?!\z).*\R?/m';
$str = 'Line1
Line2
Line3
LastLine
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);