import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\x21[ -\\x20]|\\x22[ -\\x21]|\\x23[ -\\x22]|\\x24[ -\\x23]|\\x25[ -\\x24]|\\x26[ -\\x25]|\\x27[ -\\x26]|\\x28[ -\\x27]|\\x29[ -\\x28]|\\x2a[ -\\x29]|\\x2b[ -\\x2a]|\\x2c[ -\\x2b]|\\x2d[ -\\x2c]|\\x2e[ -\\x2d]|\\x2f[ -\\x2e]|\\x30[ -\\x2f]|\\x31[ -\\x30]|\\x32[ -\\x31]|\\x33[ -\\x32]|\\x34[ -\\x33]|\\x35[ -\\x34]|\\x36[ -\\x35]|\\x37[ -\\x36]|\\x38[ -\\x37]|\\x39[ -\\x38]|\\x3a[ -\\x39]|\\x3b[ -\\x3a]|\\x3c[ -\\x3b]|\\x3d[ -\\x3c]|\\x3e[ -\\x3d]|\\x3f[ -\\x3e]|\\x40[ -\\x3f]|\\x41[ -\\x40]|\\x42[ -\\x41]|\\x43[ -\\x42]|\\x44[ -\\x43]|\\x45[ -\\x44]|\\x46[ -\\x45]|\\x47[ -\\x46]|\\x48[ -\\x47]|\\x49[ -\\x48]|\\x4a[ -\\x49]|\\x4b[ -\\x4a]|\\x4c[ -\\x4b]|\\x4d[ -\\x4c]|\\x4e[ -\\x4d]|\\x4f[ -\\x4e]|\\x50[ -\\x4f]|\\x51[ -\\x50]|\\x52[ -\\x51]|\\x53[ -\\x52]|\\x54[ -\\x53]|\\x55[ -\\x54]|\\x56[ -\\x55]|\\x57[ -\\x56]|\\x58[ -\\x57]|\\x59[ -\\x58]|\\x5a[ -\\x59]|\\x5b[ -\\x5a]|\\x5c[ -\\x5b]|\\x5d[ -\\x5c]|\\x5e[ -\\x5d]|\\x5f[ -\\x5e]|\\x60[ -\\x5f]|\\x61[ -\\x60]|\\x62[ -\\x61]|\\x63[ -\\x62]|\\x64[ -\\x63]|\\x65[ -\\x64]|\\x66[ -\\x65]|\\x67[ -\\x66]|\\x68[ -\\x67]|\\x69[ -\\x68]|\\x6a[ -\\x69]|\\x6b[ -\\x6a]|\\x6c[ -\\x6b]|\\x6d[ -\\x6c]|\\x6e[ -\\x6d]|\\x6f[ -\\x6e]|\\x70[ -\\x6f]|\\x71[ -\\x70]|\\x72[ -\\x71]|\\x73[ -\\x72]|\\x74[ -\\x73]|\\x75[ -\\x74]|\\x76[ -\\x75]|\\x77[ -\\x76]|\\x78[ -\\x77]|\\x79[ -\\x78]|\\x7a[ -\\x79]|\\x7b[ -\\x7a]|\\x7c[ -\\x7b]|\\x7d[ -\\x7c]|\\x7e[ -\\x7d]|\\x7f[ -\\x7e]";
final String string = "ae\n"
+ "ea\n"
+ "za\n"
+ "aA\n"
+ "f$\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}