$re = '/[元一二三四五六七八九十〇]+(?=年)/m';
$str = '平成元年
平成一年
平成十年
平成十年
平成一〇年
平成十一年
平成三十年
平成三〇年';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);