re = /^(?!.* ).*/m
str = 'oneword
two words
oneword
oneword
two:words
\'oneword
\' oneword'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end