$re = '/^((?|[1-9](?=.*1\t+(?<x>0+))|[1-9]\d(?=.*2\t+(?<x>0+))|[1-9]\d{2}(?=.*3\t+(?<x>0+))|[1-9]\d{3}(?=.*4\t+(?<x>0+))|[1-9]\d{4}(?=.*5\t+(?<x>0+))|[1-9]\d{5}(?=.*6\t+(?<x>0+))|[1-9]\d{6}(?=.*7\t+(?<x>0+))|[1-9]\d{7}(?=.*8\t+(?<x>0+))))\b/Jsm';
$str = '1
12
123
12345678
123456789
1 00000000
2 0000000
3 000000
4 00000
5 0000
6 000
7 00
8 0';
$subst = "${x}$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;