// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)\s*
(
(?<type>int(?:\s+long|\s+short)?|double(?:\s+long)?|
long(?:\s+int|\s+double)?|short(?:\s+int)?|float|char)
|
(?<error>\w+|\w+\s*\,)
)
\s+
(?:
(?:
(?:
(?<error>int|double|float|char|long|short|[^,;a-zA-Z_].+?|[^,;]+?(?:\s+\w+?)+)
|
(?<id>[a-zA-Z_][a-zA-Z_0-9]*)
)
(?:\s*\[\s*[1-9]\d*\s*\])*
)
\s*
(?:\,\s*|(?=\;))
)+
\s*\;\s*").unwrap();
let string = "int
abv, cde, doub1lel,ded, cto, int1;
float ng23423, _ga45,
astories;
int af , f;
int a, b, c;int short alt ;
long double fgd [ 1 ], [1] , wef ;
char _a[1], fi [
3
] [ 10] [ 4 ] ,g[1];int qw;";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}