#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[0-9]{30}$"
Local $sString = "ddsfsf2f55fs2fs12f55sf5" & @CRLF & _
"221156551516514654303155155465" & @CRLF & _
"fsfsfsfsfsfsffsfsdwerwrerwerwr" & @CRLF & _
"rwrwrwrwrwrwerwFSFSFSFSFDsfsfsf" & @CRLF & _
"123255465476134646346846564963" & @CRLF & _
"565464ff56546464646461316fsdfs" & @CRLF & _
"5555"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")