package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<div[^>]*>([\s\S]*?)<\/div>`)
var str = `<div class="1">
abc
<div>div interna</div>
xyz
</div>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}