re = /\b(?<!\bnon[-\s])hazardous\b/m
str = 'non-hazardous
non hazardous
hazardous
non agricultural hazardous'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end