$re = '~^[A-Z]{4}[0-9]{4}$~m';
$str = 'ABCD1234
ABCD9999
XETB3345
FI35D099';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);