$re = '/[A-Z0-9]{8,16}/m';
$str = '123456780192
N1234ABC80192';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);