re = /((www\.|(http|https|ftp|news|file)+\:\/\/)[_.a-z0-9-]+\.[a-z0-9\/_:@=.+?,##%&~-]*[^.|\'|\# |!|\(|?|,| |>|<|;|\)])/
str = 'https://regex101.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end