$re = '/(^\S{2,}:\S{2,}$)|(^.*?(\n|$))/m';
$str = 'fdsfsdfdsfsd*&$~f:fdsfdsfsdfd1234?1&*@#/
ddad1asda:dd
sdadad:ddd
dsadsada:dsdadadsdsadsadasdsadasdasdasdadasdsad
dd:dd
d:dsdasdasdad
ds:dsf
d:d
ygygygyjgjh:ggyigiygiygiygi
d:ddh
dsfsdfdsfsfdsfsdfsdfs
:
dsdsdsdsdd;sdsdsdsdd
dsdsdsdsdd@sdsdsdsdd
h
j
j
fsdfsdfdsfsdfdsf
sdfsdfsdfsddsfsdf
dsfsdfsdfsdfdsfsdf
,
.';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;