import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\"raw\":\\s*\")(?:.*?)([0-9]{4})(?:[^\"]*\")";
final String string = "{ \"comment\": \"This regex is designed to turn raw fields in CSL-JSON into year only, leaving literal CE BC?E dates alone\"\n"
+ "{\"raw\": \"2006\"}\n"
+ "{\n"
+ " \"raw\": \"2006 Feb\"\n"
+ "}\n"
+ "{\"raw\": \"Feb 2021\"}\n"
+ "{\"raw\":\"2006 Mar 12\"}\n"
+ "{\"raw\":\"2006-12-12\"}\n"
+ "{\"raw\":\"2006 02 04\"}\n"
+ "{ \"raw\": \"2006-12-12\" }\n"
+ "{\"raw\": \"350 B.C.E.\"}\n\n\n";
final String subst = "\"raw\": \"$1\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}