import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<strong>.*?COSPAR.*?<\\/strong>(.*)<\\/p>\\s<p>(.*)\\s<p><strong>Launch Date:<\\/strong>(.*?)<strong>Launch Vehicle:<\\/strong>(.*?)<strong>Launch Site:<\\/strong>(.*)";
final String string = "<p><strong>NSSDCA/COSPAR ID:</strong> 2009-038F</p>\n"
+ "<p>ANDE 2, the Atmospheric Neutral Density Experiment 2, is a pair of microsatellites (Castor and Pollux) launched from Cape Canaveral on STS 127 on 15 July 2009 at 22:03 UT and deployed from the payload bay of the shuttle on 30 July 2009 at 17:22 UT.</p>\n"
+ "<p><strong>Launch Date:</strong> 2009-07-15<br/><strong>Launch Vehicle:</strong> Shuttle<br/><strong>Launch Site:</strong> Cape Canaveral, United States<br/></p>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}