$re = '/({(?:\s*)?mainUrl:\s?\')[^\']+(\',\s*?ver:\s?")[^"]+(",?\s*.*\s*)(visible:\s?)(?:true|false)(\s*?})/m';
$str = '{
mainUrl: \'test.mysite.com\',
ver: "1.0",
secUrl: \'/\',
visible: true
}';
$subst = "$1production.mysite.com$22.0$3$4true$5";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;