#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^;\s*(?<comment>.+?)\s*$\n)?^\s*(?!;)(?<name>.*?)\s+(?<className>.*?)\s+(?<type>.*?)\s+(?<value>.*?)$"
Local $sString = "" & @CRLF & _
"stu IN MX 15 1826300652.mail.outlook.com." & @CRLF & _
"sse IN MX 20 71892d7f2309e64ba6aa36cf20484a.mail.outlook.com." & @CRLF & _
"pridns IN A 202.203.208.33" & @CRLF & _
"; 云大电子党建平台" & @CRLF & _
"pridns IN AAAA 2001:250:2800:2::33" & @CRLF & _
"secdns IN A 202.203.208.34" & @CRLF & _
"secdns IN AAAA 2001:250:2800:2::34" & @CRLF & _
"" & @CRLF & _
"_acme-challenge IN TXT oRKINFT0awvpteMfKl--2AKSZWujeeBg0FBudZKsxW0" & @CRLF & _
"" & @CRLF & _
"ynu-public-dns-a IN A 113.55.13.51" & @CRLF & _
"ynu-public-dns-a IN AAAA 2001:250:2800::13:51" & @CRLF & _
"ynu-public-dns-b IN A 113.55.13.52" & @CRLF & _
"ynu-public-dns-b IN AAAA 2001:250:2800::13:52" & @CRLF & _
"" & @CRLF & _
"@ IN A 39.129.5.118" & @CRLF & _
"www.sap IN CNAME lb-http-xn" & @CRLF & _
"www.sxzx IN CNAME lb-http-xn" & @CRLF & _
"; site-cluster IN A 202.203.208.28" & @CRLF & _
";site-cluster IN AAAA 2001:250:2800:2::28" & @CRLF & _
"; 云大电子党建平台" & @CRLF & _
"www.yddzdjpt IN CNAME lb-http" & @CRLF & _
"site-group IN A 202.203.208.4" & @CRLF & _
";site-group IN AAAA 2001:250:2800:2::41" & @CRLF & _
"; 站群系统域名统一放在这里" & @CRLF & _
"; 站群网站:云南大学工商管理与旅游管理学院" & @CRLF & _
";www.bts IN CNAME site-group" & @CRLF & _
"; 档案馆" & @CRLF & _
"www.archives IN CNAME site-group" & @CRLF & _
"; 未知" & @CRLF & _
"www.cas IN CNAME site-group" & @CRLF & _
"; 三严三实和忠诚干净担当专题教育" & @CRLF & _
"sysshzcgjdd IN CNAME site-group" & @CRLF & _
"www.211 IN CNAME site-group" & @CRLF & _
"; 云南大学地方政府治理中心网站信息发布" & @CRLF & _
"www.lgg IN CNAME site-group" & @CRLF & _
"; 站群网站:中国高等教育学会教育信息化分会第六届理事会第二次常务理事会议" & @CRLF & _
"; cheia2015 IN CNAME site-group" & @CRLF & _
"; 东陆书院" & @CRLF & _
"www.dlsy IN CNAME site-group" & @CRLF & _
"; 东陆校区综合管理服务中心" & @CRLF & _
"www.dlzhfw IN CNAME site-group" & @CRLF & _
"; 云南大学党委办公室" & @CRLF & _
"www.dwoffice IN CNAME site-group" & @CRLF & _
"; 云南大学研究生院" & @CRLF & _
"www.grs IN CNAME site-group" & @CRLF & _
"; 云南大学艺术与设计学院" & @CRLF & _
"www.art IN CNAME site-group" & @CRLF & _
"; 云南大学茶马古道文化研究所" & @CRLF & _
"; www.chamagudao IN CNAME site-group" & @CRLF & _
"; 云南省高校数字媒体技术重点实验室" & @CRLF & _
"www.dmtlab IN CNAME site-group" & @CRLF & _
"; 云南大学经济学院" & @CRLF & _
"www.eco IN CNAME site-group" & @CRLF & _
"; 地理环境研究所" & @CRLF & _
"www.ger IN CNAME site-group" & @CRLF & _
"; 云南大学高等教育研究院" & @CRLF & _
"www.hie IN CNAME site-group" & @CRLF & _
"; 云南大学基建处 (网站改版0523)" & @CRLF & _
"www.jjc IN CNAME site-group" & @CRLF & _
"; 国际河流与生态安全研究院" & @CRLF & _
"www.ires IN CNAME site-group" & @CRLF & _
"; 云南大学现代分析测试中心" & @CRLF & _
"www.labct IN CNAME site-group"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")