import re
regex = re.compile(r"(?s)(?<=proc )(?P<type>\w+?);(?!.+\bproc ).*(?=NOTE: PROCEDURE )")
test_str = ("proc format;\n\n"
"2018-04-12T07:45:52,430 INFO [00000009] :t707982 - 26 \n"
"2018-04-12T07:45:52,430 INFO [00000009] :t707982 - 27 \n"
"2018-04-12T07:45:52,433 INFO [00000009] :t707982 - 35 '0010','0019'=\"08\"\n"
"2018-04-12T07:45:52,434 INFO [00000009] :t707982 - 36 '0005','0007','0011','0013'=\"09\"\n\n"
"NOTE: There were 95219365 observations read from the data set WORK.TESTE1.\n"
"2018-04-12T07:55:41,536 INFO [00000018] :t707982 - NOTE: The data set WORK.TESTE1 has 95219365 observations and 9 variables.\n"
"2018-04-12T07:55:41,537 INFO [00000018] :t707982 - NOTE: Compressing data set WORK.TESTE1 decreased size by 34.04 percent. \n"
"2018-04-12T07:55:41,538 INFO [00000018] :t707982 - Compressed is 92230 pages; un-compressed would require 139823 pages.\n\n"
"proc format; \n\n"
"2018-04-12T08:45:52,430 INFO [00000009] :t707982 - 26 \n"
"2018-04-12T08:45:52,434 INFO [00000009] :t707982 - 36 '0005','0007','0011','0013'=\"09\"\n"
"NOTE: There were 95219365 observations read from the data set WORK.TESTE2.\n"
"2018-04-12T08:55:41,536 INFO [00000018] :t707982 - NOTE: The data set WORK.TESTE2 has 95219365 observations and 9 variables.\n"
"2018-04-12T08:55:41,537 INFO [00000018] :t707982 - NOTE: Compressing data set WORK.TESTE2 decreased size by 34.04 percent. \n"
"2018-04-12T08:55:41,538 INFO [00000018] :t707982 - Compressed is 92230 pages; un-compressed would require 139823 pages.\n"
"2018-04-12T08:55:42,230 INFO [00000018] :t707982 - NOTE: PROCEDURE format used (Total process time):\n"
"2018-04-12T08:55:42,231 INFO [00000018] :t707982 - real time 2:07.03\n"
"2018-04-12T08:55:42,231 INFO [00000018] :t707982 - user cpu time 1:56.98\n"
"2018-04-12T08:55:42,231 INFO [00000018] :t707982 - system cpu time 39.22 seconds\n"
"2018-04-12T08:55:42,231 INFO [00000018] :t707982 - memory 3159502.32k")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")