re = /^\w+[-.w]*@(?!(?:gmail|yahoo|live)\.com$)\w[-.\w]*\.\w{2,4}$/m
str = 'mail@company.com
mail@gmail.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end