#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<(td) class="headerCovTableEntryLo">([0-9.]+)\s?%<\/\1>"
Local $sString = "" & @CRLF & _
"<head>" & @CRLF & _
" <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">" & @CRLF & _
" <title>LCOV - .info.cleaned</title>" & @CRLF & _
" <link rel="stylesheet" type="text/css" href="gcov.css">" & @CRLF & _
"</head>" & @CRLF & _
"" & @CRLF & _
"<body>" & @CRLF & _
"" & @CRLF & _
" <table width="100%" border=0 cellspacing=0 cellpadding=0>" & @CRLF & _
" <tr><td class="title">LCOV - code coverage report</td></tr>" & @CRLF & _
" <tr><td class="ruler"><img src="glass.png" width=3 height=3 alt=""></td></tr>" & @CRLF & _
"" & @CRLF & _
" <tr>" & @CRLF & _
" <td width="100%">" & @CRLF & _
" <table cellpadding=1 border=0 width="100%">" & @CRLF & _
" <tr>" & @CRLF & _
" <td width="10%" class="headerItem">Current view:</td>" & @CRLF & _
" <td width="35%" class="headerValue">top level</td>" & @CRLF & _
" <td width="5%"></td>" & @CRLF & _
" <td width="15%"></td>" & @CRLF & _
" <td width="10%" class="headerCovTableHead">Hit</td>" & @CRLF & _
" <td width="10%" class="headerCovTableHead">Total</td>" & @CRLF & _
" <td width="15%" class="headerCovTableHead">Coverage</td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td class="headerItem">Test:</td>" & @CRLF & _
" <td class="headerValue">.info.cleaned</td>" & @CRLF & _
" <td></td>" & @CRLF & _
" <td class="headerItem">Lines:</td>" & @CRLF & _
" <td class="headerCovTableEntry">399</td>" & @CRLF & _
" <td class="headerCovTableEntry">1019</td>" & @CRLF & _
" <td class="headerCovTableEntryLo">39.2 %</td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td class="headerItem">Date:</td>" & @CRLF & _
" <td class="headerValue">2016-11-07</td>" & @CRLF & _
" <td></td>" & @CRLF & _
" <td class="headerItem">Functions:</td>" & @CRLF & _
" <td class="headerCovTableEntry">22</td>" & @CRLF & _
" <td class="headerCovTableEntry">67</td>" & @CRLF & _
" <td class="headerCovTableEntryLo">32.8 %</td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr><td><img src="glass.png" width=3 height=3 alt=""></td></tr>" & @CRLF & _
" </table>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
"" & @CRLF & _
" <tr><td class="ruler"><img src="glass.png" width=3 height=3 alt=""></td></tr>" & @CRLF & _
" </table>" & @CRLF & _
"" & @CRLF & _
" <center>" & @CRLF & _
" <table width="80%" cellpadding=1 cellspacing=1 border=0>" & @CRLF & _
"" & @CRLF & _
" <tr>" & @CRLF & _
" <td width="50%"><br></td>" & @CRLF & _
" <td width="10%"></td>" & @CRLF & _
" <td width="10%"></td>" & @CRLF & _
" <td width="10%"></td>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")