re = /(?<=\()\d+/m
str = '10 lessons (40h 25m)
2 lessons (50m)
25 lessons (3d 10h 23m)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end