using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"tar(.(bz2|gz|lz(ma)?|xz|Z))?|t(bz?2?|gz|lz|xz|Z)$";
string input = @"tb2
tbz
tbz2";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}