re = /^(?:2018|201[0-7]|200[0-9]|1[0-9]{1,3}|[0-9]{1,3})\.[a-zA-Z]\.[a-zA-Z]@\w+(?:\.\w+)*\.com\.co$/m
str = '0.j.g@cloudmail.com.co
50.j.g@cloudmail.com.co
444.j.g@cloudmail.com.co
999.j.g@cloudmail.com.co
2018.j.g@cloudmail.com.co
2019.j.g@cloudmail.com.co
2020.j.g@cloudmail.com.co'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end