const regex = /file type.*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('file type.*', 'g')
const str = `Symbols from "/mnt/home/petros/test".
Local exec file:
\`/mnt/home/petros/test', file type elf64-x86-64.
Entry point: 0x1050
0x0000000000000318 - 0x0000000000000334 is .interp
0x0000000000000338 - 0x0000000000000368 is .note.gnu.property
0x0000000000000368 - 0x0000000000000388 is .note.ABI-tag
0x0000000000000388 - 0x00000000000003ac is .gnu.hash
0x00000000000003b0 - 0x0000000000000458 is .dynsym
0x0000000000000458 - 0x00000000000004da is .dynstr
0x00000000000004da - 0x00000000000004e8 is .gnu.version
0x00000000000004e8 - 0x0000000000000508 is .gnu.version_r
0x0000000000000508 - 0x00000000000005c8 is .rela.dyn
0x00000000000005c8 - 0x00000000000005e0 is .rela.plt
0x0000000000001000 - 0x0000000000001017 is .init
0x0000000000001020 - 0x0000000000001040 is .plt
0x0000000000001040 - 0x0000000000001048 is .plt.got
0x0000000000001050 - 0x00000000000011d9 is .text
0x00000000000011dc - 0x00000000000011e5 is .fini
0x0000000000002000 - 0x0000000000002017 is .rodata
0x0000000000002018 - 0x0000000000002054 is .eh_frame_hdr
0x0000000000002058 - 0x0000000000002144 is .eh_frame
0x0000000000003db8 - 0x0000000000003dc0 is .init_array
0x0000000000003dc0 - 0x0000000000003dc8 is .fini_array
0x0000000000003dc8 - 0x0000000000003fb8 is .dynamic
0x0000000000003fb8 - 0x0000000000004000 is .got
0x0000000000004000 - 0x0000000000004010 is .data
0x0000000000004010 - 0x0000000000004018 is .bss
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}