re = /(?<=^AttributeReferenceID\s{4})(\d+)/m
str = 'AttributeReferenceID 123
AttributeReferenceID 456
AttributeReferenceID 789
ISCCAttributeReferenceID 091281 [09123na0]
ISCCAttributeReferenceID 123012 [i1208221]
ISCCAttributeReferenceID 091221 [0oas9019]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end