package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mU)\b\w*[À-ž]\w*\b`)
var str = `страницы</title>
words like “übermäßig” or “Mäuseöhrchen”. We’re here to bring some clarity:`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}