package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[^.!?]+[.!?]+`)
var str = `This is the first sentence. Second one??? Third.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}