$re = '/(?<![\/|@|.])HMCT/m';
$str = 'www.foo.bar/HMCT GmbH/krasses Bild.jpg
.HMCT GmbH/krasses Bild.jpg
alt="HMCT GmbH"
@HMCT.de';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);