$re = '/^(?:https?:\/\/)?(?!test\.ua)([^\/"\s]+)/im';
$str = 'goolge.com
https://goolge.com/test
goolge.com
test.ua';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);