# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\s*\([^()]+\)$"
test_str = ("Data/3d/Maps/28_rock_rc/SpeedTree/palms/images/palm_trunk.dx11.dds.dvpl (80.79 KiB)\n"
"Data/3d/Maps/28_rock_rc/stones/images/karelia_tiletex_blue.dx11.dds.dvpl (595.11 KiB)\n"
"Data/3d/Maps/28_rock_rc/stones/images/karelia_tiletex_blue.tex.dvpl (42 B)\n"
"Data/3d/Maps/29_skit_sk/work\n"
"Data/3d/Maps/29_skit_sk/work/images\n"
"Data/3d/Maps/29_skit_sk/work/images/yamato_01.dx11.dds.dvpl (153.60 KiB)\n"
"Data/3d/Maps/29_skit_sk/work/images/yamato_01.tex.dvpl (42 B)\n"
"Data/3d/Maps/29_skit_sk/work/images/yamato_02.dx11.dds.dvpl (145.80 KiB)\n"
"Data/3d/Maps/29_skit_sk/work/images/yamato_02.tex.dvpl (42 B)\n"
"Data/3d/Maps/34_forgecity_fc/buildings/images/bld_metlife.dx11.dds.dvpl (507.31 KiB)\n"
"Data/3d/Maps/34_forgecity_fc/buildings/images/bld_tower_plant.dx11.dds.dvpl (164.39 KiB)\n"
"Data/3d/Maps/34_forgecity_fc/buildings/images/build_1.dx11.dds.html (586.68 KiB)\n"
"Data/3d/Maps/34_forgecity_fc/buildings/images/build_2.dx11.dds.txt (145.84 KiB)\n"
"Data/3d/Maps/34_forgecity_fc/buildings/images/build_3.dx11.dds.gif (152.02 KiB)\n"
"Data/3d/Maps/34_forgecity_fc/buildings/images/build_4.dx11.dds.dvpl (148.57 KiB)\n"
"Data/3d/Maps/34_forgecity_fc/buildings/images/chrysler_building.dx11.dds.dvpl (515.44 KiB)\n"
"Data/3d/Maps/34_forgecity_fc/landscape/grass/forgecity_GrassMap.dx11.dds.dvpl (184.37 KiB)\n"
"Data/3d/Maps/hangar_prem_2018_birthday_6\n"
"Data/3d/Maps/hangar_prem_2018_birthday_6/birthday_5")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.