using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-zA-Z\<\>//]){0}\s(?<name>[a-zA-Z]+)=?(""(?<value>[A-Za-z\d\s?%&=;_:.\-\/\\%]*)"")?";
string input = @"<iframe width=""560"" height=""315"" src=""https://www.youtube.com/embed/dQw4w9WgXcQ"" title=""YouTube video player"" frameborder=""0"" allow=""accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture"" allowfullscreen></iframe>
<div style=""width: 100%; height: 0px; position: relative; padding-bottom: 56.250%;""><iframe src=""https://streamable.com/e/z1plzy"" frameborder=""0"" width=""100%"" height=""100%"" allowfullscreen style=""width: 100%; height: 100%; position: absolute;""></iframe></div>
<iframe src=""https://www.facebook.com/plugins/video.php?height=476&href=https%3A%2F%2Fwww.facebook.com%2FReposterasporelmundo%2Fvideos%2F509220620563650%2F&show_text=false&width=476&t=0"" width=""476"" height=""476"" style=""border:none;overflow:hidden"" scrolling=""no"" frameborder=""0"" allowfullscreen=""true"" allow=""autoplay; clipboard-write; encrypted-media; picture-in-picture; web-share"" allowFullScreen=""true""></iframe>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}