re = /\d{11}|[1-9]\d{9}|[1-9]\d{4}\s\d{5}|\d{6}\s\d{5}/
str = '1234567890
01234567890
12345 67890
012345 67890
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end