import re
regex = re.compile(r"modelBuilder\.Entity<(?'type'\w+)>\(builder =>\n\s*\{(?'builder'[\w\W]+?)\}\);", flags=re.MULTILINE)
test_str = ("modelBuilder.Entity<Foobar>(builder =>\n"
" {\n"
" builder.HasKey(e => e.Id).HasName(\"PRIMARY\");\n\n"
" builder\n"
" .ToTable(\"foobar\")\n"
" .UseCollation(\"utf8mb4_0900_ai_ci\");\n\n"
" builder.HasIndex(e => e.A, \"A\").IsUnique();\n\n"
" builder.Property(e => e.D).HasColumnType(\"datetime\");\n"
" builder.Property(e => e.E)\n"
" .HasMaxLength(255)\n"
" .UseCollation(\"utf8mb4_unicode_ci\");\n"
" builder.Property(e => e.N)\n"
" .HasMaxLength(255)\n"
" .UseCollation(\"utf8mb4_unicode_ci\");\n\n"
" builder.HasOne(d => d.ANav).WithOne(p => p.BNav)\n"
" .HasForeignKey<Foobar>(d => d.Leerling)\n"
" .HasConstraintName(\"Foobar_fk\");\n"
" });")
subst = "public class $1Mapping : IEntityTypeConfiguration<$1>\\n{\\n public void Configure(EntityTypeBuilder<$1> builder)\\n {\\n$2\\n}}"
result = regex.sub(subst, test_str)
if result:
print(result)