re = /(?<=[.?!])\s+(?=[a-z])/i
str = 'Fry me a Beaver. Fry me a Beaver! Fry me a Beaver? Fry me Beaver no. 4?! Fry me many Beavers... End'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end