using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?=[a-zA-Z0-9]{4})(?![0-9]+\b)[a-zA-Z]*[0-9][a-zA-Z0-9]*\b";
string input = @"latitude 7400 ws9083r f89";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}